…und auf einmal fehlen die svg icons unter xfce4

Letzte Woche habe ich mein Gentoo wieder mal auf den neuesten Stand gebracht.
Darunter wurden auch folgende Pakete installiert, die im Zusammenspiel dafür sorgen, dass alle Icons im SVG-Format, zum Beispiel im xfce-Panel nicht mehr angezeigt werden. Auch gibt es keine Voransicht mehr in den Auswahldialogen.

  • xfce-base/xfce4-4.2.3.2
  • sys-apps/dbus-1.0.2
  • dev-libs/dbus-glib-0.72
  • x11-libs/cairo-1.2.4
  • gnome-base/librsvg-2.16.0
  • gnome-base/gnome-vfs-2.16.3
  • gnome-base/libgnome-2.16.0
  • gnome-base/libbonoboui-2.16.0
  • gnome-base/gnome-desktop-2.16.2

Bei der Installation sollte das USEFLAG svg für xfce4-4.2.3.2 gesetzt werden zum Beispiel in der Datei /etc/portage/package.use mit der Zeile „xfce-base/xfce4 svg“.

Dann tut’s aber immer noch nicht, offenbar sind da noch einige Abhängigkeiten im Argen.

Installiert jedoch gnome-base/librsvg-2.16.1, dann wird alles wieder gut.
Mit einer Zeile in /etc/portage/package.keywords, “ gnome-base/librsvg ~x86″, wird beim nächsten „emerge librsvg“,
die richtige Version gezogen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

:bye: 
:good: 
:negative:  
:scratch: 
:wacko:  
:yahoo: 
B-) 
mehr...
 

   Mit der Nutzung dieses Formulars erklärst Du Dich mit der Speicherung und Verarbeitung Deiner Daten durch diese Website einverstanden. Mehr Informationen dazu findest Du in der Datenschutzerklärung.

ALL-INKL.COM - Webhosting Server Hosting Domain Provider Blogverzeichnis - Blog Verzeichnis bloggerei.de

Diese Seite verwendet Cookies. Mit der Nutzung von tuxlog erklärst Du Dich mit der Verwendung von Cookies einverstanden. Detaillierte Informationen über die Verwendung von Cookies auf dieser Website findest Du in der Datenschutzerklärung.