wp-greet Version 1.0 – Update

Hier geht’s zur neuesten Version von wp-greet

wp-greet ist ein WordPress-Plugin, mit dem eigene Grafiken und Fotos als Grußkarten aus einem WordPress-Blog gesendet werden können. wp-greet benötigt das Plugin NextGenGallery (http://alexrabe.boelinger.com/wordpress-plugins/nextgen-gallery/) ab Version 0.83 zum Verwalten der Grußkarten, sowie WordPress Version 2.2 der höher. Getestet mit WordPress bis Version 2.5 und NextGen Gallery ist Version 0.92. Optional kann die Klasse phpMailer (http://phpmailer.codeworxtech.com/) dazu verwendet werden die Bilder als inline Grafiken per Mail zu verschicken. Ab Version 1.0 nutzt wp-greet die allgemein verfügbaren wordpress Mailklassen zum Versenden von inline Bildern.

Funktionalitäten:

  • versenden von Grusskartenmails aus einer NextGenGallery heraus (Bilder verlinkt oder inline)
  • Vergabe von Berechtigungen (Wer darf senden?)
  • protokollieren der verschickten Mails
  • Vorgabe von HTML-Blöcken für Kopf- und Fuß, sowie Betreff der Grusskartenmail
  • Angabe eines Standard-Mailreturnpfades, sowie eines Bcc Empfängers
  • Integration des Captcha! Plugins von Jose Rodriguez (a.k.a. Boriel).

Download:

wp-greet-1.0.zip 1632 Downloads

Dokumentation:

Die Dokumentation zu wp-greet hat eine eigene Seite (deutsch).
The Documentation of wp-greet has its own posting (english).

wp-greet zum Ausprobieren:

Demo-Seite auf tuxlog.de
Demo bei Barbara

Entstehung: Die Idee zu diesem Plugin stammt von Barbara Jany. Als Barbara mich fragte, ob ich nicht Lust hätte ein Grußkarten-Plugin mit ihr zusammen zu entwickeln, dachte ich zunächst, sowas gibt’s doch bestimmt schon. Weit gefehlt in der WordPress-Welt existieren tatsächlich noch Themen, zu denen niemand ein Plugin entwickelt hat und da – wie jeder schnell einsehen wird – ein Grußkarten-Plugin zwingend notwendig ist, um die Möglichkeiten von WordPress auszuschöpfen, haben wir uns gemeinsam ans Werk gemacht und dieses Plugin entwickelt. Jetzt da wir unser Baby veröffentlichen, sind wir sehr gespannt was die WordPresser auf der Welt davon halten und freuen uns auf Feedback von Euch.

Historie:
2008-04-04 v0.9 initial release

2008-04-14 v1.0 added captcha support, removed dependency to
phpmailer package

Haftungsauschluß: Wie immer, übernehmen wir keine Garantie oder Haftung für evtl. entstehenden Schäden bei der Anwendung unserer Software, die wir nach bestem Wissen und Gewissen entwickelt und im Rahmen unserer Möglichkeiten getestet haben. (Barbaray Jany & Hans Matzen)

&nbsp

Kommentare

  1. webmaster:

    hallo meszi,

    wp-greet zieht sich die sprache aus der einstellung in wordpress. wenn du dein wordpress auf deutsch eingestellt hast (in der wp-config.php für WPLANG de_DE eingestellt hast), dann sollte eigentlich auch die deutsche übersetzung gezogen werden.

    gruß
    hans

    Antworten

  2. mészi:

    hallo,

    ich probiere mich gerade am wp-greet plugin aus. leider bekomme ich die deutsche übersetzung nicht aktiviert, obwohl im plugin-ordner ein „lang“ ordner mit den dateien „de_DE.mo“ und „de_DE.po“ ist. auf der admin-oberfläche habe ich auch keinen hinweis gefunden. kann mir jemand einen tipp geben?

    cu,
    mészi.

    Antworten

  3. webmaster:

    hallo Dietmar,

    meine antwort findest du auf der doku seite auf deinen eintrag.
    gruß
    hans

    Antworten

  4. Dietmar:

    tolles tool, nur bekomme ich immer diese fehlermeldung und weiß nicht, was tun!

    Fatal error: Cannot redeclare class PHPMailer in /homepages/34/d89920058/htdocs/wordpress/dietmarhochmuth.info/wp-includes/class-phpmailer.php on line 21

    Besten Gruß,
    Dietmar

    Antworten

  5. webmaster:

    hallo soho,

    ein interessanter fehler. hast du alle wp-greet dateien in das richtige verzeichnis kopiert?
    es sieht aus als ob die setup.php fehlt und stattdessen ein andere setup.php findet, die sich aber nicht unterhalb deines open_basedir verzeichnisses befindet und daher nicht geladen werden darf.

    gruß
    hans

    Antworten

  6. Soho:

    Hi Hans,
    ich kann das wp-greet plugin leider nicht aktiveren. genutzte versionen:
    wordpress:2.5.1 nextgen: 0.96. ich erhalte beim versuch das plugin zu aktiveren folgende meldung:
    Warning: main() [function.main]: open_basedir restriction in effect. File(/setup.php) is not within the allowed path(s): (/var/www/vhosts/lobumedia.de/httpdocs:/tmp) in /var/www/vhosts/lobumedia.de/httpdocs/wp-content/plugins/wp-greet/wp-greet.php on line 36
    Warning: main(setup.php) [function.main]: failed to open stream: Operation not permitted in /var/www/vhosts/lobumedia.de/httpdocs/wp-content/plugins/wp-greet/wp-greet.php on line 36
    Fatal error: main() [function.require]: Failed opening required ’setup.php‘ (include_path=‘.:‘) in /var/www/vhosts/lobumedia.de/httpdocs/wp-content/plugins/wp-greet/wp-greet.php on line 36

    rechte sind ausreichend vorhanden…aber ich weiß nimmer weiter. danke für deine hilfe!
    grüße, soho

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

:bye: 
:good: 
:negative: 
:scratch: 
:wacko: 
:yahoo: 
B-) 
mehr...
 
ALL-INKL.COM - Webhosting Server Hosting Domain Provider Blogverzeichnis - Blog Verzeichnis bloggerei.de